SSL/TLSとはで書きましたが、SSLの古いバージョンには重大な脆弱性があります。
SSL/TLSにおいて「暗号化通信を確立するとき、弱い暗号スイートの使用を強制することによって、解読しやすい暗号化通信を行わせる」というダウングレード攻撃があります。
これに加え、SSL2.0を強制的に使わせるバージョンロールバック攻撃は、SSL2.0の致命的な脆弱性であると、IPAの資料に記載があります。
https://www.ipa.go.jp/files/000045645.pdf